Back to overview
Downtime
Ongoing incident: India Network Impacted
Apr 19, 2024 at 5:48pm UTC
Affected services
India Region (ind.)
Resolved
Apr 22, 2024 at 12:22pm UTC
Issue has been resolved
Affected services
Created
Apr 19, 2024 at 5:48pm UTC
Players might have issues when connecting to our India network. The Infra Team is working on resolving the issue.
Affected services